How can we help?

What browsers are compatible with Banzai?

Banzai is built for the web, targeting desktop computers, tablets, and mobile phones. In order to use Banzai, you must have one of the following browsers installed to access it.

  • Google Chrome
  • Firefox
  • IE 10+
  • Safari 5+
Have more questions? Submit a request